Various versions of Netscape Communicator earlier than version 4.76 have potentially serious security holes. In an effort to provide the maximum security we recommend that you upgrade to the most current commercial release of Netscape Communicator or Navigator.